Older Wallet Compatibility

The newer wallets do not conflict with the core code of Worldcoin, therefore the older versions ‘8.6.2’ can still function correctly for the time being. V1.1.0 is not compatible with older versions of Windows. If you have Windows XP or Mac, please download version 8.6.2 but beware because it will not have the newest graphics, update system etc. V1.1.0 ensures when an update comes you don’t have to worry about losing any coins on an outdated wallet, that’s if we do make some important security updates. We strongly suggest you install a newer OS so that we can support your needs. These wallets will not work forever but we’ll try to support them for as long as possible.

LATEST NEWS

LAST TWEETS

RECENT VIDEOS

thumbnails

STAY TUNED